Copyright 2006 Item Software Inc., All Rights Reserved

The Software Product, any media, printed materials, “online” or electronic documentation, instructional material, or similar materials relating the software are owned by ITEM SOFTWARE and are protected by copyright laws and international copyright treaties as well as other intellectual property laws and treaties. All other matters including use and distribution of the Software Product shall be in accordance with Item Software's SOFTWARE LICENSE AGREEMENT and/or with the prior written permission of Item Software, Inc. The copyright and the foregoing restrictions on the copyright use extend to all media in which this information may be preserved.

This guide may not, in whole or in part, be copied, photocopied, translated, or reduced to any electronic medium or machine-readable form without prior consent, in writing, from Item Software. The information in this guide is subject to change without notice and Item Software assumes no responsibility for any errors that may appear in this document.

Item QRAS and iQRAS are trademarks of Item Software, Inc.

All company and product names are the trademarks or registered trademarks of their respective companies.

Printed in U.S.A.
Rev.3, November, 2006

Item Software, Inc.
+1.714.935.2900

Based upon Item QRAS
Version 2.0
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONTENTS</td>
<td>3</td>
</tr>
<tr>
<td>PREFACE</td>
<td>5</td>
</tr>
<tr>
<td>PURPOSE OF THIS GUIDE</td>
<td>5</td>
</tr>
<tr>
<td>STRUCTURE</td>
<td>5</td>
</tr>
<tr>
<td>CONVENTIONS</td>
<td>6</td>
</tr>
<tr>
<td>INTRODUCING ITEM QRAS</td>
<td>7</td>
</tr>
<tr>
<td>WHAT IS ITEM QRAS?</td>
<td>8</td>
</tr>
<tr>
<td>HARDWARE AND SOFTWARE REQUIREMENTS</td>
<td>10</td>
</tr>
<tr>
<td>TECHNICAL SUPPORT</td>
<td>11</td>
</tr>
<tr>
<td>IQRAS PROJECT BASICS</td>
<td>13</td>
</tr>
<tr>
<td>CREATING A NEW PROJECT</td>
<td>14</td>
</tr>
<tr>
<td>STANDARD FEATURES OF THE iQRAS WORKSPACE</td>
<td>16</td>
</tr>
<tr>
<td>THE iQRAS TOOLBARS</td>
<td>20</td>
</tr>
<tr>
<td>NAVIGATING THE iQRAS MENUS</td>
<td>22</td>
</tr>
<tr>
<td>SAVING A PROJECT</td>
<td>26</td>
</tr>
<tr>
<td>CLOSING A PROJECT</td>
<td>26</td>
</tr>
<tr>
<td>EXITING iQRAS</td>
<td>26</td>
</tr>
<tr>
<td>A PRACTICAL EXAMPLE</td>
<td>27</td>
</tr>
<tr>
<td>THE SCENARIO</td>
<td>27</td>
</tr>
<tr>
<td>CREATE THE PROJECT AND BUILD THE HIERARCHY</td>
<td>29</td>
</tr>
<tr>
<td>DEFINE THE MISSION PHASES</td>
<td>32</td>
</tr>
<tr>
<td>DEFINING OPERATIONAL TIME INTERVALS AND IE APPLICABILITY</td>
<td>33</td>
</tr>
<tr>
<td>CREATING EVENT SEQUENCE DIAGRAMS</td>
<td>37</td>
</tr>
<tr>
<td>INITIATING AND PIVOTAL EVENT QUANTIFICATION</td>
<td>44</td>
</tr>
<tr>
<td>ESD CREATION, CONTINUED</td>
<td>51</td>
</tr>
<tr>
<td>ASSOCIATING ESDS TO OTIS</td>
<td>57</td>
</tr>
<tr>
<td>ANALYSIS</td>
<td>59</td>
</tr>
<tr>
<td>IQRAS FAULT TREE ANALYSIS</td>
<td>67</td>
</tr>
<tr>
<td>INTRODUCTION</td>
<td>68</td>
</tr>
<tr>
<td>CREATING A FAULT TREE SYSTEM</td>
<td>69</td>
</tr>
<tr>
<td>Constructing the system</td>
<td>70</td>
</tr>
<tr>
<td>What is a Gate?</td>
<td>71</td>
</tr>
<tr>
<td>Types of Gates</td>
<td>71</td>
</tr>
<tr>
<td>What is an Event?</td>
<td>72</td>
</tr>
<tr>
<td>Types of Events</td>
<td>72</td>
</tr>
<tr>
<td>Adding Gates and Events</td>
<td>72</td>
</tr>
<tr>
<td>How to Create and Add a Quantification Model into an Event</td>
<td>75</td>
</tr>
<tr>
<td>Performing Analysis</td>
<td>79</td>
</tr>
</tbody>
</table>
Preface

Item Quantitative Risk Assessment System (iQRAS) is a PC based software tool for conducting Probabilistic Risk Assessment (PRA) for any engineered system that can be modeled. iQRAS bridges the gap between the professional risk analyst and the design engineer.

Purpose of this Guide

This guide contains information to help you start using Item QRAS. The guide presents information in a tutorial format, and is intended to explain the basic functions of the software. Advanced concepts are included in the online help system, which can be accessed from the Help menu within the Item QRAS software.

Structure

This guide contains the following chapters:

Chapter 1      Introducing Item QRAS.
Chapter 2      iQRAS Project Basics
Chapter 3      A Practical Example iQRAS Project
Chapter 4      iQRAS Fault Tree Analysis
Chapter 5      Other Important iQRAS Functions
Conventions

Throughout this guide, Item QRAS and iQRAS are used interchangeably.

In examples, an implied carriage return occurs at the end of each line, unless otherwise noted. You must press the ENTER key at the end of a line of input.

The following table lists the special conventions used in this guide.

<table>
<thead>
<tr>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>Words in bold indicate the user enters / clicks that button or menu in the software.</td>
</tr>
<tr>
<td>RETURN</td>
<td>Words in bold indicate names of keys and key sequences.</td>
</tr>
<tr>
<td>ALT – P</td>
<td>A hyphen between key names indicates a key combination. For example, pressing ALT - P means to hold down the ALT key while also pressing the P key.</td>
</tr>
</tbody>
</table>
CHAPTER 1
Introducing Item QRAS

Welcome to Item QRAS. This chapter introduces Item QRAS and basic PC requirements. It contains the following sections:

- What is Item QRAS?
- Hardware and Software Requirements
- Getting Technical Support

The remaining chapters of this guide describe Item QRAS and how you can use it to analyze your engineered systems.
What Is Item QRAS?

Item Quantitative Risk Assessment System (iQRAS) is a PC based software tool for conducting Probabilistic Risk Assessment (PRA) for any engineered system. iQRAS bridges the gap between the professional risk analyst and the design engineer. Developed originally by NASA to assist them to focus on the areas of the Space Shuttle program with the most risk, iQRAS has become a world-class tool for engineers to truly quantify risk.

How does it work?

iQRAS is a PRA tool designed to incorporate state-of-the-art PRA technology with a user interface that is easily used by managers and design engineers. Those with less experience in the methodology and nuances of PRA will find iQRAS quite useful. The front end of the traditional PRA process involves the identification of accident initiators; this is often done with the use of a Master Logic Diagram. In the case of iQRAS, the front end is a graphical, point-and-click, tree-like picture of the system being modeled, together with its elements, subsystems, and sub-subsystems. It is to this hierarchy that you attach known accident initiators or failure modes.

The iQRAS System Hierarchy feature can be used to construct a hierarchical structure of the system risk model, analogous to a Master Logic Diagram. iQRAS has a Mission Timeline module which contains data on subsystem run times (start and stop times), which are adjusted to changing mission profiles. Timing data is used in other parts of QRAS to calculate failure probabilities.

iQRAS also facilitates the construction of Event Sequence Diagrams (ESDs), which logically describe the scenarios in which initiators can lead, through intermediate or pivotal events, to undesirable end states such as catastrophic failure. The success or failure of pivotal events may represent parts of a fail-safe design or even emergency procedures. iQRAS enables you to further develop the initiators and pivotal events in terms of contributing causes (basic events) using fault trees. A Fault Tree Editor, also with an intuitive graphical interface, is provided to build the fault trees which are then logically linked according to the ESD models.

iQRAS accommodates initiators, pivotal events, and their contributing basic events quantified in a variety of ways, including:

- failure probability point estimates with uncertainty bounds
- failure probabilities which are functions of multiple physical variables such as temperature, pressure, etc.
- standard reliability functions selected by the user and supplied by iQRAS
- limit-state functions which support failure probability determinations in cases such as classical stress-strength interference
iQRAS Fault Tree includes fast, exact solutions (no rare event approximations or other short cuts employed in other PRA computer codes). One of the advanced features of iQRAS is its capability to handle system dependencies. You can model “common cause” failures within an ESD through the construction of Common Cause Groups that include applicable fault tree basic events. iQRAS automatically generates conventional event trees for the risk scenarios, as well as the minimal cut sets of system fault trees and ESD end states.

Nearing the end of the PRA process, iQRAS aggregates ESD end state probabilities to produce intermediate and/or top-level end state (e.g., catastrophic failure) probabilities and their uncertainty bounds. Among the results is a prioritization of the “risk drivers” (i.e., the initiators that contribute the most risk to the system).

**What kinds of questions can iQRAS help answer?**

“What is the best estimate of catastrophic failure (e.g., loss of crew or vehicle) probability per mission?”

- iQRAS will calculate a system’s top-level and intermediate subsystem-level catastrophic failure probabilities and their uncertainty bounds, based on the current mission’s timeline.

“What subsystem failure modes contribute the most risk to an engineered system?”

- The answer could be the basis for identifying possible system upgrades.

“If we could redesign subsystem A to eliminate a particular failure mode, what would be the benefit in decreased system risk?”

- The answer could be compared to the risk benefits (and associated cost) of redesigning subsystem B.

“If we could redesign subsystem A to reduce the probability of failure due to a particular failure mode by X percent (e.g., 50 percent), what would be the benefit in decreased system risk?”

- The answer could help judge the total risk benefit of a proposed subsystem redesign.

“If we change the failure probability/uncertainty of failure mode A, how does that affect the bounds on the risk of system catastrophic failure?”

- If your uncertainty about the failure probability of a particular initiator has a significant affect on your confidence in the system under assessment, that uncertainty can be improved, perhaps through additional testing or more detailed analysis to improve our state of knowledge.
Chapter 1: Introducing Item QRAS

Hardware and Software Requirements

Minimum recommended system configuration for Item QRAS:

- Microsoft Windows XP Professional, Microsoft Windows 2003/2000, Microsoft Windows NT 4.0 (SP6 or later) or Microsoft Windows 95/98.
- Intel Pentium II or AMD K6-II 450MHz-based PC or higher.
- 128MB RAM (256MB or higher is recommended)
- 200MB free disk space
- A 17-inch or larger monitor with display properties set to a minimum of 1280 X 768 pixels
- Mouse or other pointing device
- CD-ROM drive

Less capable machines (such as Pentium 133 with Windows 95/98) can run Item QRAS, but the performance may be less than ideal. The use of additional memory, faster processors, bigger monitor or stable operating system such as Microsoft Windows XP/2000 will directly improve performance and capacity. The amount of memory (RAM) used is dependant upon the size of the model. On an average the software uses additional 100 MB for every 1000 gates and events.
Technical Support

Our technical support staff is always ready to help you with installing or using Item QRAS. If you need technical support, contact Item Software using any of the following methods:

<table>
<thead>
<tr>
<th></th>
<th>Americas</th>
<th>Europe, Far East, Middle East, and Australia</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Telephone</strong></td>
<td>+1.714.935.2900</td>
<td>+44(0) 1489 885085</td>
</tr>
<tr>
<td><strong>Fax</strong></td>
<td>+1.714.935.2911</td>
<td>+44(0) 1489 885065</td>
</tr>
<tr>
<td><strong>Email</strong></td>
<td><a href="mailto:technical_support@itemsoft.com">technical_support@itemsoft.com</a></td>
<td><a href="mailto:support@itemuk.com">support@itemuk.com</a></td>
</tr>
<tr>
<td><strong>Web site</strong></td>
<td><a href="http://www.itemsoft.com">www.itemsoft.com</a></td>
<td><a href="http://www.itemuk.com">www.itemuk.com</a></td>
</tr>
<tr>
<td><strong>Physical address</strong></td>
<td>Technical Support</td>
<td>Technical Support</td>
</tr>
<tr>
<td></td>
<td>Item Software, Inc.</td>
<td>Item Software UK</td>
</tr>
<tr>
<td></td>
<td>2190 Town Centre Place, Suite 314</td>
<td>1 Manor court</td>
</tr>
<tr>
<td></td>
<td>Anaheim, CA 92806 USA</td>
<td>Barnes Wallis Road</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fareham, Hampshire</td>
</tr>
<tr>
<td></td>
<td></td>
<td>PO15 5TH, UK</td>
</tr>
</tbody>
</table>

Please have your product name, version number, and system configuration information available so that the Item Software technical support staff can process your support requests as efficiently as possible.
A iQRAS Project is a collection of hierarchies, timelines, Event Sequence Diagrams, Fault Tree diagrams, and Analysis results. Each of these items are created within the iQRAS application, and are stored in a folder on your PC with the same name as your Project.

This chapter includes information about:

- Creating a New Project or Opening an Existing One
- Navigating the iQRAS interface
- Saving a Project
- Closing a Project
- Exiting iQRAS
Creating a New Project
Creating a project is the starting point for any system analysis in iQRAS. Once a project is created, you create the system hierarchy, timelines, and diagrams that provide the foundation for your analysis.

1. Launch iQRAS via the Item QRAS icon on your Desktop.

2. The initial iQRAS screen appears. Check the Event Sequence Diagram option, then click OK. If you have an existing Project, click either Open or Recent File options. (Fault Tree systems can also be started by checking the Fault Tree Analysis option.)
3. The iQRAS main screen opens, displaying the “root” for you to begin building your hierarchy, as well as the menu selections and icons across the top. If this is an existing Project, you would see your Project hierarchy displayed in iQRAS as it was last saved.
Standard Features of the iQRAS Workspace

This section describes the general functionality of the features and command menus within the iQRAS workspace. The standard features described are used throughout the entire application.

The iQRAS workspace is the area you use to build your systems. It consists of menus, toolbars, and windows. All of the features in the workspace follow standard Windows Graphical User Interface (GUI) conventions. The workspace features a Multiple Document Interface (MDI), which allows you to:

- Choose which windows to display, close, minimize, move and resize. You can drag and drop iQRAS windows and toolbars anywhere within the MDI workspace.
- Open multiple project files so you can build several projects at the same time and compare analysis results.
- Drag and drop components between projects. This feature allows you to create a new project quickly by reusing components from other projects.

If you do not see all of the windows that you prefer, use the **Window** menu at the top of the screen to open the windows you wish.

The Project Window

Located in the upper middle of the screen (default location); the project window shows the project hierarchy with the included systems. Cross tabs located on the edge of the project window allow you to select an active project when multiple projects are open. The following items and their icons are shown in the Project window hierarchy tree:

- **Project File Header**: Shown with a filing cabinet icon - Listing includes project name and other information.
- **System Type Header**: Shown with a file cabinet drawer icon – Systems are grouped by analysis type, Fault Tree, ESD, etc.
- **System Files**: Shown with multiple pockets, file folder icon - Listing includes system information and sum of reliability data for the total system.
The System Window
Located in the lower middle (default location); the system window shows the hierarchy of the system selected in the Project window. The following items and their icons are shown in the System window hierarchy tree.

System Header: Shown with a multiple pockets file folder icon - Listing includes system information and sum of reliability data for the total system.

The Data View Window
The Data View window is located on the right hand side of the workspace (default location). The window displays and entry of data in the Dialog view, displays a grid or spreadsheet view of system data, creates and displays diagrams. Tabs along the bottom of this window allow for selection and the display of the different types of information.

The Data View panel has multiple tabs:

The Dialog tab displays information for the item selected in the Project or System Window and is the primary location for viewing and editing data. The tabs and information presented in the Dialog tab vary depending on the selection made in the Project or System Window.
The **Grid** tab shows the selected element data in tabular format. You can edit data in the Grid window.

If you want to zoom in on a particular section of the grid, select the desired cells and select **Grid View Zoom In** from the **Layout** Menu.

If you want to see more of the grid, select **Grid View Zoom Out** from the **Layout** Menu. Select **Grid View Zoom 100%** from the **Layout** Menu to restore the grid to normal size.

The **Fault Tree and ESD** tabs display the diagram that is selected in the System window. On this area you create and edit the diagrams according to your analysis goals.
iQRAS Information Bar

The iQRAS workspace includes an information bar located along the bottom of the screen. The left-hand side of the information bar includes the name and brief information on toolbar icons. The right-hand side indicates information on size of the active system such as the number of Gates and the number of Events included in the system.

Resizing iQRAS Windows

Another feature that allows expanding the active window viewing area is the split screen control located between the Project, System, and Data windows. Passing the mouse pointer through this area will locate this control. The pointer changes from a simple arrow to a double solid line with small arrows pointing up and down or left and right. Once the pointer has changed, you can press and hold the left mouse button while dragging the mouse, which will resize the outer boundaries of the window.

The iQRAS Toolbars

Toolbars provide quick access to iQRAS functions. Initially, only the Default and Project toolbars are displayed. Drawing toolbars are activated when a drawing is made active.

Default Toolbar

Immediately below the pull-down menus resides a group of buttons that form the Default (Main) Toolbar enabling you to access the more frequently used and standard windows menu options:

- New Project, Open, Save
- Cut, Copy, Paste, Delete, Undo
- Print and Help

![Default Toolbar Buttons]

Both the contents of the menus on the menu bar and the toolbar change according to which analysis application is currently in use. The purpose of each button in the toolbar can be displayed in the form of a “tool tip” that appears alongside the button when the cursor is placed over the button.

Project Toolbar

The Project Toolbar displays all available systems analysis modules. This Toolbar is used to create a new systems in the Project window.

![Project Toolbar Buttons]
Analysis Toolbar
A unique Analysis toolbar appears in the top right side by default when an analysis module and system is opened and/or is made active. This toolbar is different and unique to each type of analysis being used.

Fault Tree

ESD

The icons shown on the Analysis Toolbar are used for adding various elements to a System.

Drawing Toolbars
A series of small drawing toolbars are made active when the canvas is made active. These toolbars appear along the bottom of the workspace and consist of Align Nudge, Rotate, Layout, Canvas, Graph and Zoom. They contain drawing tools to aid in the creation of professional looking diagrams.

Customizing Toolbars
iQRAS allows you to add and delete or customize the workspace toolbars. You can also create your own custom toolbars that contain the functions you use most frequently. Settings – Customize is the menu location to perform these actions.
Navigating the iQRAS Menus

The iQRAS menus are your gateway into the many aspects of your Project. In the following chapter, you will use each menu to build the example Project. Commonly used menu options have associated Toolbar icons for ease of use.

The **File** menu is used to open and save projects, as well as libraries. Also printing, reporting, converting, and import/export functions are located here.

<table>
<thead>
<tr>
<th>File</th>
<th>Add</th>
<th>Edit</th>
<th>Layout</th>
<th>Settings</th>
<th>A</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New Project" /></td>
<td><img src="image" alt="Add" /></td>
<td><img src="image" alt="Edit" /></td>
<td><img src="image" alt="Layout" /></td>
<td><img src="image" alt="Settings" /></td>
<td><img src="image" alt="A" /></td>
</tr>
<tr>
<td>Open Project...</td>
<td>Ctrl+O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Project</td>
<td>Ctrl+S</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Project As</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close Project</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>New Library</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Library</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Library</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Saved Library As</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close Library</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Diagram</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save Grid...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Print" /></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Preview</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Setup...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Setup...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Convert</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Recent Files</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The **Add** menu is context sensitive and will display the items you can add to a diagram or system. Elements, sub-systems, initiating and pivotal events, fault tree gates, and events, will all be displayed depending upon the context of the system selected.

The **Edit** menu contains typical Windows based options such as Undo, Cut, Copy, Paste, and Find/Replace. Additionally, in the context of an ESD, options to connect ESDs to OTIs and to define End States exist on this menu.
The **Layout** menu is context sensitive and shows you the descriptors that can appear on the Master Logic and other panels. Sorting and Grid panel controls are also located here.

The **Settings** menu displays options that control the precision of results, items displayed, workspace functionality, and how the project files are backed up and names generated.

The **Analysis** menu is where you define, perform, and view analysis results.
Use the **Tools** menu for options such as Mathematica™ or Bayesian Updates if installed.

Use the **Window** menu to control and open any closed workspace panels. By default, all panels are open except for the Library window.

Access the iQRAS Help files via the **Help** menu.
Saving a Project

iQRAS follows standard Windows save functionality. Each saved project is stored in a named, separate folder containing a project file with an extension of .IQP. The folder and .IQP file names are the same for ease of location. Only the .IQP file contains project information. The other files in the folder are backup or temporary in nature.

Closing a Project

To close the active project, select Close Project from the File menu. iQRAS closes the active project, with changes.

Exiting iQRAS

To exit iQRAS, select Exit from the File menu. iQRAS closes all open projects. If an open project contains unsaved changes, iQRAS prompts you to save the project before closing it.
CHAPTER 3
A Practical Example

The best way to learn is to actually perform the tasks associated with the topic being learned. So, in an effort to accomplish that goal, we have contrived a practical example for you to use as a foundation towards learning iQRAS and the associated iQRAS Fault Tree module.

In this example, we are focusing on an aircraft, its systems, and how they impact the success of the mission during the various phases of the mission. While not an exhaustive analysis, it will give you the foundation you need to apply iQRAS and iQRAS Fault Tree to your specific needs.

The Scenario
Our aircraft has the following systems, components, and initiating events:

- Engine System
  - Fuel System
    - Fuel Tank
    - Leak
- Aerodynamics
  - Wing System
    - Wing Extend Motor
    - Stuck
- Avionics
  - Auto Pilot System
    - Auto Pilot Control
      - Auto Pilot Control fail
      - Incorrect sensor data

Our goal is to use iQRAS to describe these elements and quantify how the failure of each, during specific phases of the mission, could impact the aircraft and the success of the mission.

Continuing the example setup, we use the following Mission Phases to describe the mission:

- Parked in the hangar
- Takeoff
- In flight
Chapter 3  A Practical Example

The next step is to define the Operational Time Intervals within each Mission Phase. These are the times during the Mission Phase that the associated Initiating Event could have an impact.

Then, for each phase of the mission, the path from an Initiating Event, through Pivotal Events to system End States (Mission Success, Failure, etc) are described with Event Sequence Diagrams (ESD). Typically you model within “failure space” when building ESDs and Fault Trees. You can model in “success space” with iQRAS, but you need to be sure the logic of your diagrams are correct and the probabilities you enter are appropriate for the logic.

To quantify the risk for each of the Initiating and Pivotal Events, we will use several models available within iQRAS, ranging from simple Demand or Time Based, to the more sophisticated Fault Tree model.

Once all of this modeling is finished, the analysis can begin. You can analyze at any level in the hierarchy. Additionally, you can perform sensitivity analysis, providing “what if” scenarios to further refine your view of the possible outcomes.

Shall we begin?
Create the Project and Build the Hierarchy

1. As you learned in the previous chapter, open iQRAS and create and save a new Project. Give it a name you can remember. We suggest for this example: “Aircraft_mission_analysis”

At this point you see a blank iQRAS screen with the default Master Logic element visible.

2. Rename the Root element to “Aircraft” by first selecting it, then editing the Name field in the Dialog panel.

3. With the newly named Aircraft “root” still selected, add the Engine System element to the Aircraft. Use either the toolbar or the Add menu to accomplish this.
4. Select the newly created element on the screen, then rename it to “Engine System”. Change both the **Name** and **Designator** to meaningful descriptions.

5. Continue to use the **Add** menu or toolbar to build the hierarchy for the Engine System. Add the Fuel System and Fuel Tank sub-systems, then the Leak Initiating Event (IE). When you are done, your screen looks like this:

![Hierarchy Diagram](image)

Note: To turn off the **Designator** field data on the **Master Logic** panel, open the **Layout** menu and deselect the **Designator** option.
6. Finish defining the Aircraft hierarchy by adding the other systems and initiating events for our example. When you are done, your screen will look like this: (Be careful that the indent/relationships are correct)
Define the Mission Phases

With the hierarchy in place, we can now define the phases of the mission for our aircraft. A Mission Phase can be just a few seconds in duration, or many days. It is up to you how these phases are defined. We suggest that you enter the phases in the order they would naturally occur during the mission to maintain clarity.

7. Select the Aircraft at the highest level, then click the Mission Phase(s) tab on the Dialog panel.

8. Use the Add button to begin defining the various phases of your mission. Enter the name, start/end times and units for the phase, then click Update to store the new phase. In our example, we are using the following:

- Parked in the hangar – 2 days before the mission (T-2 days)
- Takeoff – 11 minutes
- In flight – 5 hours (300 minutes)

Note: The time units available are Hours, Minutes, Seconds, and Days.
In this example, the Mission Phases are time-sequential. The next phase begins at the end time of the previous phase. While not a mathematical requirement, it helps with clarity if you standardize on the time units for the entire mission. Aside from the T-2 days phase, we chose to use minutes as the unit of time for all phases.

**Defining Operational Time Intervals and IE Applicability**

This specific example requires us to define the Operational Time Intervals (OTI) for each of the sub-systems (those elements directly above the Initiating Events) onboard our Aircraft. An OTI is a specific length of time that the sub-system is being considered, whether it is operational or not. For example, if a particular sub-system is operational for half of the mission phase, then non-op for the remaining time, you should build two OTIs for the sub-system; one for the operational time, and the other for the non-op time. (Although, you could ignore the non-op time, but systems can still fail during non-op time!)

Using the *Parked in the hangar* phase of our mission as a reference, we want to focus on the OTI for the Fuel Tank. For this phase, the tank is non-op, but we still wish to consider the impact a leak would have on our mission. So, based on that, we need to define an OTI for the Fuel Tank during this phase.

9. Select the Fuel Tank in the Hierarchy, then…

10. Open the **OTI** tab on the Dialog panel.
11. Select the Parked in hangar phase, then click the Add OTI button.

12. Enter –2 days for the Start time, then 0 for the End time. Note the Current Mission Phase Time is given to you in the screen as a reference. (If you make a mistake, click the Remove OTI button and start again) Your screen will look like this:

You can enter a meaningful name for the OTI as desired.
13. For the Mission Phases in the drop-down box, define a single OTI for each. Be careful to honor the start/end times for each phase/OTI relationship. When you are done, you will have a single OTI defined for each Mission Phase.

<table>
<thead>
<tr>
<th>Sub System</th>
<th>Operational Time Interval (OTI) Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mission Phases:</td>
<td>Mission Phase Time</td>
</tr>
<tr>
<td>In flight</td>
<td>Start: 11</td>
</tr>
<tr>
<td>In flight</td>
<td>Start: 11</td>
</tr>
</tbody>
</table>

14. Repeat the previous OTI steps for the remaining sub-systems. If a Mission Phase does not apply to a sub-system, do not create an OTI for it.

- Wing Extend Motor – Hints…
  - Make 2 OTIs under only the In flight Phase:
  - One that starts at 100 minutes and ends at 101 minutes
  - Another that starts at 200 minutes and ends at 201 minutes
  - (Reason: The wings are only extended/retracted before and after a certain time period during the In flight Phase)

- Auto Pilot Control – Hints…
  - OTI only needed for “In flight” Phase, starts at 21 minutes and ends at 301 minutes
  - (Reason: The AutoPilot is only used a few minutes after takeoff, during the flight, then turned off a few minutes before landing.)

15. When finished defining the OTIs, move your mouse cursor back to the Leak Initiating Event in the Hierarchy, then click to highlight it.
16. Open the OTI tab on the Dialog panel for the Leak. It is on this table where you associate the Leak IE with the appropriate OTIs in the Mission Phases.

17. For the Leak, click the box for each OTI/Mission Phase, since a leak in the tank could be an issue during any of the Mission Phases. Use the following table as a guide to associate the other IE's to the Mission Phases.

<table>
<thead>
<tr>
<th>IE/MP</th>
<th>Parked in hangar</th>
<th>Takeoff</th>
<th>In flight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leak</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Stuck</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Auto Pilot</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Control fail</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Incorrect sensor data</td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

At this point you have defined the Hierarchy of the systems, the Mission Phases, the Operational Time Intervals, and determined the associations of the Initiating Events to the Phases/Intervals. The next step is to create the Event Sequence Diagrams for each IE.
Creating Event Sequence Diagrams

An Event Sequence Diagram (ESD) is a graphical method of describing the paths from an Initiating Event (IE) to any number of mission outcomes or effects of the IE, through the series of Pivotal Events (PE). A PE is an event after the IE where the outcome is either Occurred (failure) or Not Occurred (not failed).

For example: A leak in a tank occurs. Is it detected? Is it repaired? Is the leak exposed to an environment that can cause an explosion? What are the different outcomes that can happen? (Mission Success/Failure, Loss of Crew and Vehicle?) Shown below is a sample ESD for the Leak IE while Parked in the Hangar in our example.

A key point to make is that you need to create an ESD for each Mission Phase’s OTI that the IE is being considered. The reason for this is that the event sequence could be different for the IE, depending on the Mission Phase and OTI. For example: The leak can be repaired while it is in the hangar, but while in flight, the Repair PE is not possible. Moreover, the Spark PE may be more likely In Flight, so you would use a different failure model during that phase. (More on that later)
Back to our example, the following ESDs need to be created for each Phase’s OTI. It may seem like a long list, but in reality it is only 5 distinct ESDs.

- Leak
  - Parked in Hangar – ESD #1
  - Takeoff - ESD #1.1
  - Inflight - ESD #1.2
- Stuck
  - Inflight OTI 1 – ESD #2
  - Inflight OTI 2 – ESD #2.1
- AutoPilot Control fail
  - Inflight – ESD #3
- Incorrect sensor data
  - Inflight – ESD #4

18. Select the Event Sequence Diagram system in the middle panel, then open the ESD drawing window.
19. The Leak IE is the starting point for the diagram. Notice the ESD Toolbar on the screen.

20. The next step is to define the End States for your diagrams. These are all of the possible end states for your ESD, based upon the paths from the Initiating Event. (You could define these at any time, but doing this up front is convenient.) Select the Leak IE in the hierarchy, then the **Edit** menu.
21. The next step is to build the ESD for the Leak IE during the Parked in Hangar phase of the mission. For our example, we will use the following Pivotal Events (PE) to arrive at the End States:

- Failure to Detect
- Failure to Repair
- Spark

22. Select the Pivotal Event icon on the Tool Bar, then hover your cursor over the IE until the PE box appears to the right. Your diagram appears initially as below:
23. Click the IE to attach the new PE to the IE. Your diagram now appears as below:

Note: The Name/Designator is automatically generated by iQRAS. You can and will change them later as desired.

24. Be sure the PE icon is selected in the Tool Bar, then hover over the PE you just added. Click the PE to attach another PE to the right. Your diagram now looks as follows:

25. Now select the End State icon in the Tool Bar, then hover/click the “PE 2” to add the End State. Your diagram now looks as follows:

26. Right-click the End State, then choose Parameters from the menu that appears. From the End States window that appears, choose the “LOCV” state type (Loss of Crew/Vehicle), then click OK.
27. Your diagram now looks as follows:

28. Right-click the IE and each PE, choose **Parameters**, then rename them to suit our example. IE 1 = Leak, PE 1 = Detection, and PE 2 = Repair.

Note: When you rename the IE or PE, the event is also quantified with a 1 for convenience. You can and will change the quantification in later steps.
29. Continue adding and defining the PEs and End States to suit our example. When you are done, your Leak ESD diagram for the Parked in Hangar Phase looks as follows:
(Quantification numbers will appear as a result of future steps.)

These numbers will not appear as yet.
Chapter 3  A Practical Example

Initiating and Pivotal Event Quantification

Now that you have your Initiating and Pivotal Events defined with Event Sequence Diagrams, you can begin to quantify the probability of these events occurring. Each IE and PE must be quantified for the Analysis module of iQRAS to provide you with complete results. iQRAS has a rich suite of quantification models ranging from popular parametric distributions (Normal, Lognormal, etc.) to functions of random variables.

Creating or selecting a quantification model associates a probability distribution with an event (initiating or pivotal event in the ESD, or basic event in a fault tree). After a probability distribution is associated with an event, iQRAS uses it as the model for quantifying the risk of that event; the likelihood of the occurrence/non-occurrence of the event. This model is also called an uncertainty distribution because one cannot be absolutely be sure that the mean probability is the true probability. The uncertainty distribution shows by how much the probability of occurrence can vary and the likelihood that any value within this range is the true probability of failure.

Point Value

iQRAS enables quick quantification of events by way of a point value for the probability. You can either enter a point value directly or use a slider bar to select the value. This is the default approach used within iQRAS, which might not suit all situations. More complete quantification approaches require the use of the following models.

Direct/Demand Based Models:

Events which occur at the specific time (absolute mission time or time relative to the occurrence of a previous event) that an item is called upon (demanded) to function. The outcome of such an event is binary, either success or failure, yes or no, etc. The failure of components to start belongs to this class of events (e.g., AutoPilot fails to start or Wing motor fails to operate). The event is quantified by a probability of occurrence/non-occurrence and an uncertainty distribution.

Events which occur over an interval of time, for which the probability of failure over the length of the interval is expressed as a point estimate and an uncertainty distribution. In effect, the time interval is considered to be a single demand and the item’s performance is classified as either success or failure (e.g., the failure probability of landing gear tire may be expressed as a point value with an uncertainty distribution). In this sense, the success or failure of the tire in that interval is a demand based event.

Direct/Time Distributed Model:

The time of occurrence of an event over a specified time duration is a random variable and the probability that an event occurs before a specific time is defined by a time-to-occurrence distribution (reliability function in iQRAS).
Fault Tree:
The event is decomposed into a logical combination of smaller events (basic events). Basic events have a probability of occurrence associated with them. The probability of the initiating or pivotal event is calculated as a function of the probabilities of the basic events.

30. Begin the quantification selection process by selecting the Leak IE in the ESD. Then right-click and select Parameters from the menu.

31. The Parameters window appears, listing IE details and the various models you can choose from. For our example, select Direct Model, then click the Quantification button.
32. The Quantification Model Selection window appears, showing the Demand and Time based models that are available. For our example, choose **Time-Distributed – Reliability Function (Exponential)**.

33. Click **Next…** to begin defining the distribution details. For our example, we will assume 1 leak occurs every 1000 days in the hangar, +/- a few days. Enter your data to match that on the following screen, then click **Evaluate**.
You may experiment with different values/settings to more closely model the risk of the leak occurring in the hangar. Be sure the unit you use for Lambda matches that of the Mission Phase you are evaluating for; in our example, it is Days.

34. Based upon your criteria, iQRAS evaluates the model and presents the results to you as follows. Click **Accept** to move forward. Click **Do not Accept** to go back to the model screen and make adjustments.
It should be clear from these numbers that the longer the aircraft spends in the hangar, the more likely it will experience a leak.

35. When you are done evaluating, click **Save** on the distribution details window. This returns you to the Leak IE **Parameters** window.

36. Click **OK** on the **Parameters** window to return to the ESD diagram.
37. The IE appears with quantification results listed on the ESD diagram.
38. The next step in quantifying is to quantify the Pivotal Events in the ESD. Each PE in the ESD must also have a failure model, and optionally a time duration for the event.

39. Right-click the Failure to Detect PE then select **Parameters**.

40. Select **Direct Model – Quantification** as before to open the QMS window. Assuming that the Leak can be detected any time during the hangar phase, select the **Success/Failure – Point estimate and Uncertainty** model option, then click **Next**...
Note that this and the following value selections produce a success/failure model with very little distribution. This is what we want since we are modeling the detection of a leak as either detected or not at any time during the hangar phase.

41. Select a Normal Distribution, with a Mean of 0.1 and a Standard Deviation of .001. Click Evaluate, Accept the results, then click Save.

42. Perform model selection for the other two PE in the ESD (Failure to Repair and Spark). Be sure to click Save when finished with each.

- Failure to Repair: Point Value = 0.20
- Spark: Direct Model =
  - Time-Distributed, Exponential
  - Duration = 2.0 Days
  - Weibull, Scale = 0.02, Shape = 1.5
ESD Creation, continued…

At this point, you have an ESD for the Leak while the aircraft is in the hangar.

43. Rename the ESD you just created to “Leak PIH ESD #1” using the name field on the Dialog panel.

44. To validate your ESD, select it then perform an Analysis. (Analysis – Perform) You will see the validation steps displayed in a window and the analysis will either succeed or fail. If it fails, you need to determine the issue from the validation steps window. You will also see the results listed at each End State on the canvas.

You also need to create ESDs for the other Phases of the mission. ESDs for the same IE may be different due to the conditions that exist during other phases. For example, it is not possible to repair the leak during, takeoff or in flight. The next steps guide you through creating the remaining ESDs for the Leak.

- Leak
  - Parked in Hangar – ESD #1 = completed
  - Takeoff - ESD #1.1
  - Inflight - ESD #1.2

To simplify matters, you will be making a copy of ESD #1 then make a few changes to it as ESD #1.1.

45. Right-click the Leak PIH ESD #1 then choose Copy from the menu.
46. Move your cursor to the Project level at the top, middle of your screen. Right-click, then select Paste.

47. You now see a copy of the first ESD for the Leak.

48. Rename the copied ESD to “Leak Takeoff ESD #1.1”.
49. Open the ESD Diagram panel. Right-click the Failure to Repair PE, then select **Delete – Delete Branch**. Notice that everything under that PE is deleted after you confirm the deletion.

Now your diagram looks like this…
50. Because the Failure to Repair PE is not possible during this phase of the mission (Takeoff), we have asked you to delete it and replace it with an End State of MR (Return). Most likely the aircraft would have to return to base once the Leak has been Detected. Your diagram now looks as follows:

51. Now you have an ESD that you can use to apply to the other phases of the mission for the Leak IE. Perform a copy/paste of the Takeoff ESD for the In flight phase of the mission. Rename the copied ESDs to suit the Mission Phase

- Leak
  - Parked in Hangar – ESD #1 = completed
  - Takeoff - ESD #1.1 = completed
  - Inflight - ESD #1.2
52. Continue by creating ESDs for each remaining IE. You can make your diagrams as simple or as complicated as you wish. The following examples are suggestions only.

Note: You can run an analysis on any ESD to clear up any construction errors or missing logic. Simply select the ESD and click the **GO** icon, or **Perform** from the **Analysis** menu. The analysis will run and show you any errors. You can view the ESD results via the **Results Summary** icon or the option on the **Analysis** menu.

- Stuck
  - Inflight – WEM Inflight ESD #2 and #2.1
  - Stuck IE quantification = point value = 0.001
  - Failure to Compensate quantification = point value = 0.5
Chapter 3  A Practical Example

- AutoPilot Control fail
  - Inflight – AP Inflight ESD #3
  - APC fail IE quantification = point value = 0.00001
  - AP Off fail quantification = point value = 0.03

- Incorrect sensor data
  - Inflight – AP inflight ESD #4
  - Incor data IE quantification = point value = 0.00001
  - Failure of crew quantification = point value = 0.15
**Associating ESDs to OTIs**

Now that you have several ESDs to work with, it is time to associate them with the appropriate OTIs in preparation for the analysis. Making this association is critical as the behaviour of a particular subsystem during a particular time interval is determined by the ESD logic and quantifications. The analysis will error out if this association is not made.

53. Select OTI 1 in the Master Hierarchy panel.

54. Select **Edit – Select ESD for OTI** menu option. Choose Leak PIH ESD #1 from the list then click **OK**.
55. If you make an error, you can also remove an ESD from an OTI using the **Edit** menu option.

56. Associate each ESD you created with each OTI in the Master Hierarchy panel.

57. Select **Show OTI's ESD Name** in the Layout menu to display the associated ESD name.
Analysis

iQRAS provides several different approaches to performing analyses of a system, sub-system, IE, or an entire root such as our example aircraft. You can perform analyses at any level of your hierarchy.

To continue our example, we will focus on the Leak, and the systems it is associated with.

58. Select the **Fuel System** in the Master Hierarchy. This is the level at which you will perform the analysis.
59. Select **Analysis - Perform** from the iQRAS top menu bar.
60. The **Progress** window appears, listing each validation and success/failure step during the analysis. A quick review of this window will show the problem areas if any.
61. Click the **Result Summary** icon from the main Toolbar, or the **Analysis** menu. Via the resulting window you can select and view the results of your analysis.

62. Select the LOCV end state at the bottom of the list, then choose the **Quantitative Result Total** tab on the window, then click the **Quantify** button. This populates the chart, of which you can display either the PDF or CDF distributions. Log axis is also available.
63. The results show that the LOCV end state has a 0.0001316% mean probability of occurring due to the logic of the ESD and OTIs associated with the Fuel System element. This probability is the aggregate of the probabilities for all end states of type LOCV under the Fuel System.

Note that the Results View has a number of tabs and options to display the results of the analysis. The following steps will acquaint you with the options available to you and a brief interpretation of the results of the example system thus far.
64. Move now to the **Quantitative Result Ranking** tab for a more detailed look at the situation. Choose the first end state, **Fire**, which is the largest percent of the total. When you choose the end state, the other tabs across the top become selectable as well.

65. The default view is showing the **Ranking by Scenario Probability**, which you can then view the **CutSets**, **Uncertainty**, **Pivotal Events**, and **Importance Ranking** tabs. If you choose **Ranking by Initiating Event**, you can view the **Event Tree** results tab.

66. With the Fire end state selected, click the **CutSets** tab, then click the **Compute** button. Listed will be the events going back from the end state to the original initiating event.

67. Click the **Pivotal Events** tab to view the details of these key elements of the cut-set.
68. Click the **Importance Ranking** tab, then the **Compute** button to view the relative importance measure of each element of the cut-set.

69. The **Uncertainty** tab displays the distribution for the Fire end state in our example. Click the **Quantify** button to plot the results.
70. Move back to the Quantitative Result Ranking tab, this time selecting the Ranking per Initiating Event option, then choose the top most Leak IE.

71. Choose the Event Tree tab to view the Event Tree paths and results from the Leak IE.

72. Select, then investigate the other End States (NMR and MR) and the results being shown for each. Also note the File and Canvas menu options you have to export results and control the Event Tree canvas within the Results View.
73. Close the Results View and select the Aircraft at the highest level on the Master Logic panel. Run the analysis at this level and view the results.

74. Note the addition of more elements that lead up to the LOCV end state.

The selected LOCV end state is the aggregation of all LOCV end states for the Aircraft system. Note the other LOCV end states under the Fuel System and under the Auto-pilot. You can view the probabilities of these LOCV end states by selecting them and viewing their results via the same Results View.

All end states, no matter the Mission Phase, OTI, or ESD they are a component of, are displayed on the Results View, if the analysis is run at the highest level of the system. If the analysis is run at a lower level, only the end states applicable to that level and below are analyzed. This feature allows you to focus on a particular aspect of your system, or take a higher level view.
CHAPTER 4
iQRAS Fault Tree Analysis

Fault Tree Analysis (FTA) are used during Reliability and Safety assessments to graphically represent the logical interaction and probabilities of occurrence of component failures and other events in a system. The interactions are captured using a tree structure of Boolean operator gates, which decompose system level failures to combinations of lower-level events. The analysis of Fault Trees identifies and ranks combinations of events leading to system failure, and provides estimates of the system’s failure probability.

This chapter:

- Introduces FTA systems
- Describes the iQRAS FTA features
- Outlines an example FTA system
- Describe the FTA Editor, Toolbars and Shortcut Keys
Introduction

The iQRAS Fault Tree module provides a wide variety of both qualitative and quantitative information about the system reliability and availability.

Fault Tree Analysis is a well-established methodology that relies on solid theories such as Boolean logic and Probability Theory. Boolean logic is used to reduce the Fault Tree structure into the combinations of events leading to failure of the system, generally referred to as Minimal Cut Sets, many of which are typically found. Probability Theory is then used to determine probabilities that the system will fail during a particular mission, or is unavailable at a particular point in time, given the probability of the individual events. Additionally, probabilities are computed for individual Minimal Cut Sets, forming the basis for their ranking by importance with respect to their reliability and safety impact.

Using this detailed information, efforts to improve system safety and reliability can be highly focused, and tailored to your individual system. Possible design changes and other risk-mitigating actions can be evaluated for their impact on safety and reliability, allowing for a better-informed decision making process and improved system reliability. This type of analysis is especially useful when analyzing large and complex systems where manual methods of fault isolation and analysis are not viable.

A Fault Tree is a graphical representation of events in a hierarchical, tree-like structure. It is used to determine various combinations of hardware, software, and human error failures that could result in a specified risk or system failure. System failures are often referred to as top events. A deductive analysis using a Fault Tree begins with a general conclusion or hazard, which is displayed at the top of a hierarchical tree. This deductive analysis is the final event in a sequence of events for which the Fault Tree is used to determine if a failure will occur or, alternatively, can be used to stop the failure from occurring. The remainder of the Fault Tree represents parallel and sequential events that potentially could cause the conclusion or hazard to occur and the probability of this conclusion. This is often described as a "top down" approach.

Fault Trees are composed of events and logical event connectors (OR-gates, AND-gates, etc.). Each event node's sub-events (or children) are the necessary pre-conditions that could cause this event to occur. These conditions can be combined in any number of ways using logical gates. Events in a Fault Tree are continually expanded until basic events are created for which you can assign a probability.

The top level event must be described precisely. Defining the top event too broadly leads to an open-ended tree, showing no specific cause or causes for failure. Similarly, defining the top event too narrowly leads to possible cause omissions. An FTA needs to include all possible weaknesses, faults or failures present in the system that could cause safety hazards or reliability problems. Hardware, software, and human components of the system must be included in the Fault Tree Analysis. All interactions between the system components and elements must be fully described in the FTA.
Creating a Fault Tree System

Consider the Leak you modeled in the aircraft example. While you did quantify it using a basic time distributed model, you can more accurately determine the risk of the leak if you can quantify the events leading up to a leak. Fault Tree modeling is an excellent tool for such an analysis.

Using the Leak as the Top Gate or Event, we will assume the following:

- The Leak can be caused by:
  - A corroded tank
  - A burst tank
  - A loose pipe fitting
  - A broken pipe

This arrangement leads us to a Fault Tree with 4 events and 3 OR gates.

You will then determine the Failure models for each Event. After that, performing the analysis and attaching the Fault Tree to the Leak IE are the final steps.
Constructing the system

To construct a new Fault Tree system:

1. Click the project at its highest level.

2. Select the Add menu from the menu toolbar. Select the Fault Tree System. A new Fault Tree system is added to your project. Also notice that the Top Gate (OR gate) for the system has been added to the System window in the lower left of the workspace.

3. The Dialog window for the Fault Tree system appears as well. In the Name field, rename the Fault Tree system to "Tank System". Your screen now looks as follows:
What is a Gate?
A gate is used to describe the relationship between the input and output events in a Fault Tree. For example, a specific output can occur if and only if specific input events occur. These specific inputs and outputs define each gate. A Fault Tree can have several different kinds of gates. The gate type defines the appearance of the gate symbol when drawn in the Fault Tree. In addition, the gate type determines how the inputs to the gate are logically connected for the minimal cut set analysis process.

Types of Gates
The following gates are supported in the iQRAS Fault Tree module:

**OR Gate**
The OR gate indicates that the output occurs if any one of the input events occurs.

**AND Gate**
The AND gate indicates that the output occurs if all of the input events occur simultaneously.

**VOTE Gate**
The VOTE gate indicates how many of the gate inputs need to occur to cause the gate failure to occur. For example, if the gate has four inputs and a vote of three was specified, this indicates that at least three of the gate's four inputs would have to occur to cause the gate failure to occur.

**NOT Gate**
The NOT gate indicates that the output event occurs if the input event does not occur.
NULL Gate
The NULL gate indicates a single input only. These gates are used to allow additional descriptions to be added to the fault tree for system events.

TRANSFER/Subsystem Gate
The TRANSFER/Subsystem gate indicates that this part of the fault tree is developed in a different part of the diagram or on a different page.

What is an Event?
Events appear in both Fault and Event trees, and may represent components unavailability, human errors, system failures, initiating events, etc.

Types of Events
The following types of Event are available in the Fault Tree Module:

Basic Event
A Basic event indicates an event for which failure and repair data is available.

House Event
A House event indicates whether an event is definitely operating or definitely not operating (dormant).

Undeveloped Event
An Undeveloped event indicates a system event, which is yet to be developed.

Dormant Event
A Dormant event indicates a system event with unrevealed failures until maintenance, or inspection.

Adding Gates and Events
A Fault Tree is created by adding gates and events directly into the Fault Tree diagram edit area. As you add gates and events to a fault tree diagram, the system will automatically position the diagram symbols in the diagram edit area.

Once a new Fault Tree system is added into a Project the TOP GATE is automatically created. You can enter and add gates to the Fault Tree by using the Select and Click method from the Fault Tree Toolbar or by using the Add pull-down menu.

4. Click the Fault Tree Tab to open the Fault Tree Canvas.

5. Select an OR gate symbol from the Fault Tree Toolbar with the left mouse button.

6. Move the mouse cursor to a target gate within the Fault Tree canvas.
7. Once the target gate has been reached, click the left mouse button to add.

8. Select a **Basic Event** from the toolbar and add it to the OR gate on the diagram.

9. Click the **Select Symbol** to stop adding Gates/Events.

10. Add **Descriptions** to the new Gate and Event by selecting the Gate or Event, right-click, then select **Gate or Event Parameters** from the menu.
11. Continue to add/describe Gates and Events to match the example diagram below:
How to Create and Add a Quantification Model into an Event
Quantification Models contain failure information or probability of occurrence data for human errors, environmental conditions etc. A quantification model is assigned to an event or events, for use in the Quantitative Analysis of the fault tree diagram. The selection process is similar to that used previously in quantifying Initiating and Pivotal Events in the ESD interface.

12. Right-click the first Event, then select Event Quantification from the menu

13. The QMS window opens
14. This window is where you select/define the failure model to use for the Events in the Fault Tree. Since our intention is to use this Fault Tree for the Leak while the aircraft is in the hangar, select Time-Distributed – Reliability Function (Exponential) for a Duration of 2 days. Click Next when done.

15. The Evaluation window opens. As you did in ESD, select Normal Distribution, and Mean/Standard Deviation. Enter a Mean of .5 and a Standard Deviation of .0001 for this specific model. Click Evaluate.

16. The Evaluation Results window appears. Review the results, then click Accept.
17. You are returned to the Evaluation window. Note the graph has been populated. Click Save to go to the next step.
18. Notice that the Unavailability (Q) for the Event you have just quantified now appears below the Event on the Fault Tree diagram.

19. Quantify the remaining three Events using the same steps, using your own values and analysis selections. Suggestions:

- Burst Tank – Normal, 0.0001, 1e-6, 2 Days
- Loose Fitting – Normal 0.01, 1e-3, 2 Days
- Broken Pipe – Normal, 0.0001, 1e-6, 2 Days

Note: It is also possible to use the Failure Model Library to define and store Failure Models for future use. Take advantage of this feature by opening the Quantification Model Library via the menu that appears when you right-click an Event. There you can give your model a name, define it, then select it as you wish for other Events.
Performing Analysis
The Fault Tree Module provides a method to:
- Calculate unreliability and unavailability
- Analyze Uncertainty and Sensitivity
- Analysis Common Cause Failure (CCF)
- Produce minimal cut sets
- Fault Tree Sequencing, Initiator and Enabler, Initiator Only, Enabler Only
- Determine the importance of elements in a system

To verify the Data.
20. Select Verify Data from the Analysis menu.

If the following window appears, correct the detected errors and repeat the verification.
To analyze the system:

21. In the System window, click the system header.

22. From the Analysis menu, select Perform. A dialog box displaying the progress of the analysis appears.

When the analysis is complete, the objects in the System window are updated with the analysis results.

Note: If you want to see results at different levels of the tree, select the Retain Results For... option on the Analysis menu prior to running the analysis. Choose the level you wish to see results for.
The Fault Tree canvas is also updated with the analysis results.
23. Select **Summary** from the **Analysis** menu to compute the results. The **Fault Tree Results** dialog box appears.

24. Enter a **Min. Probability** of 0, and a **Max. Order** of 4. Click **Compute**. The cut sets for your Fault Tree are displayed, along with their probability.

Note that you can export the results of the analysis via the **File** menu.
25. Click the **Uncertainty** tab, then click **Quantify**. The Uncertainty for your Top Gate is displayed in the graph.

26. Click the **Importance** tab, then click **Compute**. The Importance Measures for the events are displayed. When you are done viewing the results, close the window.
Sensitivity Analysis

It is possible to investigate how sensitive your top event probability is to changes to the probability of the events in the tree. You can choose an element or combination of elements in the tree to change their probabilities to quickly see how they impact the top gate.

27. After the analysis, select the Sensitivity option from the Analysis menu. The Sensitivity window appears.

28. Select Events, then the specific event you wish to explore. (Event 1) Check the Select checkbox.

29. Select Range, and use the default Lower (0.0) and Upper (1) bounds.

30. Click Compute.

31. View the results and explore other values and combinations of events to see how the system reacts.
Finishing up with iQRAS Fault Tree

There are many other features of the iQRAS Fault Tree module, but it is time to return to the example to make use of the Fault Tree you just constructed and analyzed. You can use this Fault Tree as a Quantification Model, just as other models available within iQRAS.

32. Save your project via File – Save Project.

33. Locate the Leak IE within the ESD for Parked in the Hangar, select it, then re-quantify it via Parameters menu selections. The Parameters window appears. Select Fault Tree.

34. Select the Tank System fault tree from the dropdown list, then click OK.

35. At this point you can rerun the analysis at any level to see how the new quantification impacts your results. You can create other fault trees to represent the probability of any IE or PE occurring within any ESD you have created.

36. Make note that when you view the results of an analysis which included a fault tree, the cut sets from the trees are displayed.
Exercise Summary

You have reached the end of the tutorial for iQRAS. There are many more features and function left unexplored, but those you have experienced are the most often used. Please refer to the Help documents included with the product for specific details of all functions.

The modeling you have performed is a combination of logic and sequence diagrams, as well as quantifying events with point values, direct models, and fault trees. We hope that this experience has exposed you to the usefulness of iQRAS and how it might be used to model much more complex systems.
CHAPTER 5
Other Important iQRAS Functions

Many important functions of iQRAS were not covered in this brief tutorial manual. The following are brief explanations of several of these functions. Details of their operation are covered in the Help text installed with the product.

Reports
Accessed via the File – Print Preview – Reports menu option, the Reports function delivers professional reports for the Project, Master Logic, ESD, and Fault Tree diagrams. You can use the built-in reports, modify them to suit your needs, or create your own from scratch.

Build your own and customize existing reports via these tabs.
Chapter 5  Other Important iQRAS Functions

Fault Tree and ESD Layout and Printing Control

All aspects of the graphics that make up each element of an ESD or Fault Tree can be modified. Via the Properties option on the right-click menu of any element, you can set such things as color, line widths, and text handling. Further, using the Set as Default option on the same menu, you can apply the settings for a specific element to the entire diagram.

Prior to performing such changes, it may be required to ungroup the graphics that make up the elements in the fault tree or ESD. Perform this operation by opening the Parameters window for any element and uncheck the Group check box.
Additionally, you can control how a fault tree or ESD is arranged when printed to a simple printer or large format plotter. Using the File – Page Setup – Diagram Page Setup menu option, you can define the page size used on the drawing canvas. This will break up the diagram into pages, making printing easier. You can then control how the diagram spans across pages using several other functions, including Transfer gates, auto-arrange, and auto-paginate.
Transfer Fault Trees and ESDs to Microsoft Word

A powerful export facility is provided that allows you to transfer data directly to Microsoft Word. To access the Microsoft Word transfer facility, select the **Microsoft Word** icon from the toolbar.

The Range window appears. Check all desired option and click OK.

The Fault Tree pages you have selected will be transferred directly into a new Microsoft Word document as graphics. Microsoft Word does not have to be active on your desktop to perform this transfer; it will open automatically. Edit and save the Word document as you would any other Word document.
Common Cause Failure Modeling

You can model common cause failure in one of two ways in iQRAS fault trees: either explicitly via a Paste Repeat of a Gate or Event, or you can model the behaviour implicitly using Common Cause Groups. Using the CCG approach, you assign the portion of the events’ probability of failure that is due to the common cause. Both Beta and Alpha approaches are supported.

Quantification Model Library

Any quantification model you create can be saved and retrieved from a library internal to the project. This will save you time if you wish to use the same model for several events. Interact with the library via the Edit menu. You can also save the library into its own file for use within another project. Failure models from existing libraries can be appended directly into the library as well.
Global Events

iQRAS supports the creation of Global Events, which can be used across Fault Tree systems. Access via the **Edit** menu. You can create, define, and quantify events, which you can then apply to any Fault Tree system in the project.
Import/Export

From Text, Excel, or Access data sources, you can import any of the following into iQRAS. From the very simple, to the very complex systems can be imported, saving construction time and effort. Additionally, any of the following and results of analysis can be exported into Text, Excel, or Access data formats. Any data that you enter or iQRAS calculates, can be exported. Access the Import/Export functions via the File menu.

- ESD Systems and Nodes
- FT Systems, Gates, Events
- Master Logic Nodes, Phases, OTI definitions, End State definitions, Consequences
- Quantification Models

The Import/Export wizard steps you through the process of matching the source data to the tables/fields within iQRAS. Depending on the complexity of the import, there may be some formatting or ID references that need to be established.
### Grid View

The Grid View provides an alternative, spreadsheet-like view of your systems. If the System or Diagram views do not suit your needs, perhaps the Grid view will. You can edit any of the fields displayed in the Grid. Additionally, via the **Grid Templates** option of the **Settings** menu, you can construct your own grid views by manipulating the columns displayed, their order, and even filtering data.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Type</th>
<th>Name</th>
<th>Description</th>
<th>Part Number</th>
<th>LCN</th>
<th>Designator</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>OR</td>
<td>Gate 2</td>
<td>Tank Problem</td>
<td>F11</td>
<td></td>
<td>Gate 2</td>
</tr>
<tr>
<td></td>
<td>BASIC</td>
<td>Event 1</td>
<td>Corroded Tank</td>
<td>F11</td>
<td></td>
<td>Event 1</td>
</tr>
<tr>
<td></td>
<td>BASIC</td>
<td>Event 2</td>
<td>Burst Tank</td>
<td>F12</td>
<td></td>
<td>Event 2</td>
</tr>
<tr>
<td></td>
<td>REPEAT Event</td>
<td>Event 5</td>
<td></td>
<td></td>
<td></td>
<td>Event 5</td>
</tr>
</tbody>
</table>

**Grid Templates**

![Grid Template Interface](image)
Converting ToolKit projects to iQRAS

IQRAS can convert Item ToolKit Fault Tree projects into iQRAS format projects. Via the File menu, use the Convert option to bring your ToolKit projects into iQRAS. Note that the quantification models are different between the two products, but the conversion is made for you.
# Index

<table>
<thead>
<tr>
<th>A</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add menu</td>
<td>23</td>
</tr>
<tr>
<td>Alpha</td>
<td>91</td>
</tr>
<tr>
<td><strong>Analysis</strong></td>
<td>55, 59</td>
</tr>
<tr>
<td><strong>Analysis</strong> menu</td>
<td>24</td>
</tr>
<tr>
<td>Associating ESDs to OTIs</td>
<td>57</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>B</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>basic events</td>
<td>8</td>
</tr>
<tr>
<td>Beta</td>
<td>91</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>C</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Closing</td>
<td>26</td>
</tr>
<tr>
<td>common cause</td>
<td>9</td>
</tr>
<tr>
<td>Common Cause Failure</td>
<td>91</td>
</tr>
<tr>
<td><strong>Compute</strong></td>
<td>62</td>
</tr>
<tr>
<td><strong>Convert</strong></td>
<td>95</td>
</tr>
<tr>
<td>CutSets</td>
<td>62</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>D</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data View</td>
<td>17</td>
</tr>
<tr>
<td>dependencies</td>
<td>9</td>
</tr>
<tr>
<td><strong>Designator</strong></td>
<td>30</td>
</tr>
<tr>
<td><strong>Dialog tab</strong></td>
<td>17</td>
</tr>
<tr>
<td>DIRECT/DEMAND BASED</td>
<td>44</td>
</tr>
<tr>
<td>DIRECT/TIME DISTRIBUTED</td>
<td>44</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>E</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit</strong> menu</td>
<td>23</td>
</tr>
<tr>
<td>End States</td>
<td>39</td>
</tr>
<tr>
<td>ESD</td>
<td>8</td>
</tr>
<tr>
<td>ESD Toolbar</td>
<td>39</td>
</tr>
<tr>
<td><strong>Evaluate</strong></td>
<td>46</td>
</tr>
<tr>
<td>Event</td>
<td>72</td>
</tr>
<tr>
<td>Event Sequence Diagrams</td>
<td>8, 37</td>
</tr>
<tr>
<td>Example</td>
<td>27</td>
</tr>
<tr>
<td>Exiting</td>
<td>26</td>
</tr>
<tr>
<td><strong>Exponential</strong></td>
<td>46</td>
</tr>
<tr>
<td>Export</td>
<td>93</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>F</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>FAULT TREE</td>
<td>45</td>
</tr>
<tr>
<td>Fault Tree Analysis</td>
<td>67</td>
</tr>
<tr>
<td><strong>Fault Tree and ESD</strong> tabs</td>
<td>18</td>
</tr>
<tr>
<td>File menu</td>
<td>22</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>G</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gate</td>
<td>71</td>
</tr>
<tr>
<td>Grid tab</td>
<td>18</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware and Software Requirements</td>
<td>10</td>
</tr>
<tr>
<td><strong>Help</strong> menu</td>
<td>25</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>29</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>I</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>IE Applicability</td>
<td>33</td>
</tr>
<tr>
<td>Import</td>
<td>93</td>
</tr>
<tr>
<td><strong>Importance Ranking</strong></td>
<td>62</td>
</tr>
<tr>
<td>Information Bar</td>
<td>20</td>
</tr>
<tr>
<td>initiators</td>
<td>8</td>
</tr>
</tbody>
</table>